Weathertech visors

Potato Wilson

Tremoraholic
Joined
Feb 2, 2021
Messages
617
Reaction Points
2,589
Location
Hangtown USA
Current Ride
2021 Latiat, 6.7
First Responder
Sheriff's Posse
Hey I installed weathertech window visors, and now my windows don’t want to close due to pressure sensitive safety controls. I have to cautiously bump the switch the last inch or so to get them to seat closed. Otherwise they open back up. Anyone have any tips for this?
 
It is something you will have to get used to with in channel window visors. Have them on my current 17 Dually. When the rubber warms up and they are in there for a while, it won't happen all the time, but will never go away completely. I'm still going to put them on my new Tremor when it shows up because I don't like the looks of the outside tape mounted ones.
 
I have them installed also. Most of the times my windows go up with no problem but every once in a while my driver's side does that.

When it happens I raise it slowly without letting the auto-up kick in.
 
Hey I installed weathertech window visors, and now my windows don’t want to close due to pressure sensitive safety controls. I have to cautiously bump the switch the last inch or so to get them to seat closed. Otherwise they open back up. Anyone have any tips for this?
Had that happen as well. I ended up going with external mounted ones. WeatherTech had no solution. Windows would not close.
 
It is something you will have to get used to with in channel window visors. Have them on my current 17 Dually. When the rubber warms up and they are in there for a while, it won't happen all the time, but will never go away completely. I'm still going to put them on my new Tremor when it shows up because I don't like the looks of the outside tape mounted ones.
It is something you will have to get used to with in channel window visors. Have them on my current 17 Dually. When the rubber warms up and they are in there for a while, it won't happen all the time, but will never go away completely. I'm still going to put them on my new Tremor when it shows up because I don't like the looks of the outside tape mounted ones.
That’s what I was afraid of. Hopefully they’ll get better. Cheers 🍻!
 
I installed the in channel ones my self and never had a problem. make sure that they are all the way in and leave them closed in the sun like mentioned
 
i had the same problem sitting in the sun didn’t help. Figured I was going to just deal with it. Took it in for the first service a month ago and they must have reset something it was fixed, which was pretty awesome since I had forgotten to mention it to them.
 
I still have the issue at times. My biggest problem was scratching the tints. Lots of dust in the air here in Vegas and you can't control how much dust gets between the window and the shade. On my Tremor whenever I get it I'll be going back to stick ons.
 
No issues with mine. Power up on the windows did not like them at first but I wiggled them in some more and all is good.

Yes wiggled in is a mechanical term :ROFLMAO::ROFLMAO:
 
Back
Top