Tremor weirdness

jmdesigns

Tremor Member
Joined
Feb 14, 2020
Messages
18
Reaction Points
14
Location
Washington
Current Ride
2020 F250 Lariat Tremor
Hi guys I have had some weird stuff happening with my truck. I have about 1k miles on it now. Ok so the first issue was I used the key fob to auto start and unlock my truck. Wife and I hopped in it take off to run some errands and the radio wouldn't come on. The radio button on the touch screen wasnt available to push. I tried the master reset and still wouldn't work. After we made a few stops I decided to try the door handle lock unlock instead of the key fob. This is my normal procedure and the radio works again 🤔.

Next issue is my truck bed camera now doesn't work. It worked when I first bought it but now it's not in color and fuzzy.
IMG_20200425_114557.jpg
 

Vigilance247

Tremor Fanatic
Joined
Mar 30, 2020
Messages
147
Reaction Points
177
Location
RGV Texas
Miltary
USN
Current Ride
2015 Corvette
Current Ride #2
On order: 2021 Iconic Silver F-350 Lariat Ultimate/Black Tremor
Not sure if this the same issue? Do you notice any condensation in the camera lens? Here is a video that talks about it. Skip to time 5:40, JD likes to talk a lot😁
 

PapaRaptor

Founding Member
Joined
Jan 22, 2020
Messages
1,750
Reaction Points
2,025
Location
Land o Cheese
Current Ride
Blue Truck
Current Ride #2
Bigger Blue Truck
My screen went blank, I pulled over to restart the engine and as soon as I put it in Park the screen went back on.
I was going on a two hour trip and with the screen blank I could not set the temps or anything. Completely helpless.
 

Lite

Founding Member
Joined
Apr 24, 2020
Messages
37
Reaction Points
47
Location
North Carolina
Current Ride
2020 F-250 Lariat 6.7
Current Ride #2
2014 Porsche Cayman S
Hi guys I have had some weird stuff happening with my truck. I have about 1k miles on it now. Ok so the first issue was I used the key fob to auto start and unlock my truck. Wife and I hopped in it take off to run some errands and the radio wouldn't come on. The radio button on the touch screen wasnt available to push. I tried the master reset and still wouldn't work. After we made a few stops I decided to try the door handle lock unlock instead of the key fob. This is my normal procedure and the radio works again 🤔.

Next issue is my truck bed camera now doesn't work. It worked when I first bought it but now it's not in color and fuzzy.View attachment 1697
My truck and the one I test drove both have this issue with the bed camera. Dealer said they have replaced bed cameras in 6 trucks. Mine goes in Wednesday for diagnosing and repair. Funny thing is occasionally it does work, but most often it does not. But it looks the same as in your photo. Maybe Ford got a bad batch of bed cameras?
 
Last edited:

Prospect

Tremor Buff
Joined
Feb 19, 2020
Messages
53
Reaction Points
52
Location
Ca
Current Ride
F250
I got a trouble alert on dash “reduced engine power” several times while driving on a dirt road in 4H. Throttle was unresponsive at those times and intermittent with out alert too. Also, outside temperature gauge was surely off by 15 degrees. 6.7
 

Worley

Founding Member
TOTM Winner
Joined
Jan 29, 2020
Messages
259
Reaction Points
411
Location
Memphis, Tennessee
Current Ride
2020 F-350 6.7 Rapid Red
Current Ride #2
2012 Harley Davidson Road Glide
I got a trouble alert on dash “reduced engine power” several times while driving on a dirt road in 4H. Throttle was unresponsive at those times and intermittent with out alert too. Also, outside temperature gauge was surely off by 15 degrees. 6.7
Sounds like you got too much Cohiba smoke in the intake.
 

Mountain Man

Founding Member
TOTM Winner
Joined
Mar 1, 2020
Messages
305
Reaction Points
358
Location
Santa Cruz Mountains
Current Ride
2020 F250 Tremor
I got a trouble alert on dash “reduced engine power” several times while driving on a dirt road in 4H. Throttle was unresponsive at those times and intermittent with out alert too. Also, outside temperature gauge was surely off by 15 degrees. 6.7
Sounds like you went into limp mode to protect the engine. Could be serious. Have you checked for any thrown codes?
 

Prospect

Tremor Buff
Joined
Feb 19, 2020
Messages
53
Reaction Points
52
Location
Ca
Current Ride
F250
Sounds like you went into limp mode to protect the engine. Could be serious. Have you checked for any thrown codes?
I plan to check soon. I had a 300 mile drive back home that had mostly normal driving at all different speeds along the way. I searched and found if a throttle sensor acts up it will do that. Other sensors could cause as well. I’m first going to check electrical connections and become familiar, then find a code reader and decide on the next steps
 

leogeo

Tremor Buff
Joined
Nov 26, 2019
Messages
89
Reaction Points
77
Location
Wyoming
Current Ride
2020 F250 Lariat Tremor
Current Ride #2
2013 Taurus SHO
Every time I step on the brake, I get a notification that my trailer is connected and I have a fault in my trailer lights, and my BLIS system has been deactivated. Pain in the wazoo.
 

Whyte Rhyno

Founding Member
Joined
Jan 17, 2020
Messages
716
Reaction Points
770
Location
Montana
Current Ride
2020 F250 Lariat 6.7 Powerstroke
Current Ride #2
1974 F250 Highboy
Every time I step on the brake, I get a notification that my trailer is connected and I have a fault in my trailer lights, and my BLIS system has been deactivated. Pain in the wazoo.
Might be some moisture in the plug. I've had that happen in the past. Try blowing it out with dry air and put some dielectric grease in the plug. See if that helps.
 

leogeo

Tremor Buff
Joined
Nov 26, 2019
Messages
89
Reaction Points
77
Location
Wyoming
Current Ride
2020 F250 Lariat Tremor
Current Ride #2
2013 Taurus SHO
Might be some moisture in the plug. I've had that happen in the past. Try blowing it out with dry air and put some dielectric grease in the plug. See if that helps.
Thanks for that idea, Ryan. I will try it. It did start on a road trip on a rainy day.
 

Whyte Rhyno

Founding Member
Joined
Jan 17, 2020
Messages
716
Reaction Points
770
Location
Montana
Current Ride
2020 F250 Lariat 6.7 Powerstroke
Current Ride #2
1974 F250 Highboy
Thanks for that idea, Ryan. I will try it. It did start on a road trip on a rainy day.
No worries. Keep us posted
 

Mountain Man

Founding Member
TOTM Winner
Joined
Mar 1, 2020
Messages
305
Reaction Points
358
Location
Santa Cruz Mountains
Current Ride
2020 F250 Tremor
My bed camera is faulty right from the get go. It is a multi colored fuzzy screen. Seems like a common issue unfortunately.
 

Lite

Founding Member
Joined
Apr 24, 2020
Messages
37
Reaction Points
47
Location
North Carolina
Current Ride
2020 F-250 Lariat 6.7
Current Ride #2
2014 Porsche Cayman S
My dealer ordered a new bed camera. Mine was doa Along with 6 other Super Duties. However the mechanic said he fixed the connectors and it might work temporarily and so far it has worked. However when the replacement comes in I’ll have them put it in.
 
Last edited:

EVAR

Tremor Newbie
Joined
Apr 14, 2020
Messages
4
Reaction Points
4
Location
So Cal
Current Ride
2020 Ford F-250 Lariat sport Tremor 6.7 Powerstroke
I just noticed that my engine block is rusty and all the aluminum is starting to corrode, have just over 1000 miles and can’t understand it. Never been in salt or near the beach. Anyone else notice this?
 
Ford Tremor Supporting Member Badge
Top