Radio presets don't display correctly

Shiftman

Tremor Buff
Joined
Dec 18, 2020
Messages
66
Reaction Points
91
Location
Georgia
Current Ride
2021 F250 XLT with Tremor kit
Current Ride #2
1984 Nissan Sentra 1.7L diesel
20210125_170350-jpg.15244

20210125_171449.jpg

Finally got a Tremor. 2021 F250 XLT.
Trying to figure out the radio...
I finally figured out how to set the radio presets, but they do not display correctly on the screen. Only the first 2 presets in the first picture are showing correctly...the other 4 are wrong, but they do play the correct station when you click or scroll to them (Sirius XM)
The FM stations do the same thing (second picture) but it's the first 2 that are wrong...it shows Sirius XM when it's actually FM. Really weird. This radio definitely a downgrade from the one in my 2018 Ram 2500, from both a sound quality and intuitiveness standpoint...and it wasn't even the higher end Alpine system. (Sorry had to vent a little).

Any idea why it does this? I've only had the truck 2 days and this is frustrating me. Thanks
 

Attachments

  • 20210125_170350.jpg
    20210125_170350.jpg
    214.8 KB · Views: 1,241
Software between Sync and Sirrus aint the greatest. Mine does it switching from Page 1 to 2 and back. Then the software "Catches" up and it will display correctly.
 
I don't have that problem, but the station highlight goes off after a couple of seconds and then goes to beginning station in the presets when I use the steering controls. It will not do it if the station is satellite. Only FM stations.
 
Mine does the same thing. Drives me crazy. They scroll in the right order, but displays wrong. I’m usually on the Home page so I don’t see it, but I still know it’s there showing the wrong station.
 
Yeah, one of "several" items that could be better, but the trucks still badass and I am good! Still waiting for Bill Ford to call me back, I got a list of several items to make their cars and trucks better....
 
Thanks for replies, I was hoping there was a fix. Maybe a future update will address this
 
I thought I was crazy until I found this thread. Ever since my software update, scrolling through my Sirius presets using the steering wheel controls has been a nightmare. Doesn't matter what station I'm on, scrolling up always takes me back to my first preset. After that, I can scroll like normal. I have contacted Sirius, taken into a Ford dealership, even done a master reset and refreshed the signal AND. NOTHING. WORKS! Anyone have any insights at all???
 
Update: My dealership is ordering a new "brain" for my SYNC (I think the name starts with an A) to see if that solves the issue. Maybe it's a combo hardware and software problem?
 
Mine used to do this. It either resolved itself after an update or I just don’t notice anymore.
 
Update: My dealership is ordering a new "brain" for my SYNC (I think the name starts with an A) to see if that solves the issue. Maybe it's a combo hardware and software problem?
Was this ever resolved. My dealer has replaced every radio component, reprogrammed, and it still has the issue.
 
I play one station that nobody else listens to anyway. Other than that, mine has always had scrambled presets.
 
I might be missing the topic the OP was discussing but I'll give my experiences.

First off the memory functions are NOT specific to the current source you are listening. The "stations" or "channels" stored in memory will change your current "source".

So if you are listening to FM source stations then use your "memory" channels to change to an Sirius Channel then radio changes source first then sets to your channel.

When listening to FM you change the station (frequency) with the other buttons/dial. Same thing when listening to Sirius.

Using the memory function is independent of the current source. It wasn't until I figured out how to set a FM station/Sirius channel into the preset memory did I realize what was really happening. I tend to stay on Sirius so all my presets/memory are Sirius channels.

Even inside the Sirius channels there are "favorites" which does nothing as far as I can tell.
 
Yea this sucks. The button only shows the logo of the Sirius presets after you touch it.
 
You probably know this/ tried this but I’ll share anyway:
I’ve done a “soft reset” and fixed mine. When a glitch appears, and it does so in a variety of ways, I reset and it works.
You hold the power(?) and media(?) buttons down for a three count. I’m not in the truck right now, but I think it’s the right combo. (Google soft reset).
You may have a bigger issue but the soft reset works fairly well.
 
I might be missing the topic the OP was discussing but I'll give my experiences.

First off the memory functions are NOT specific to the current source you are listening. The "stations" or "channels" stored in memory will change your current "source".

So if you are listening to FM source stations then use your "memory" channels to change to an Sirius Channel then radio changes source first then sets to your channel.

When listening to FM you change the station (frequency) with the other buttons/dial. Same thing when listening to Sirius.

Using the memory function is independent of the current source. It wasn't until I figured out how to set a FM station/Sirius channel into the preset memory did I realize what was really happening. I tend to stay on Sirius so all my presets/memory are Sirius channels.

Even inside the Sirius channels there are "favorites" which does nothing as far as I can tell.
The problem I am having is when I first turn on the truck the preset selected is the last station it was on. If I change the station with the screen or the steering wheel controls the station will stay selected for about 5 seconds and then go to looking not selected. The station does not change just the preset is not shown to be selected. So when I use my steering wheel controls and go up it will go to the first preset. If I go down it will go to the last preset. It only does this with FM. If I set a AM or sat station as a preset and select, it will not lose the spot on the preset list and will continue from that station to the next preset with the steering controls.
 
Got ya.
 
The problem I am having is when I first turn on the truck the preset selected is the last station it was on. If I change the station with the screen or the steering wheel controls the station will stay selected for about 5 seconds and then go to looking not selected. The station does not change just the preset is not shown to be selected. So when I use my steering wheel controls and go up it will go to the first preset. If I go down it will go to the last preset. It only does this with FM. If I set a AM or sat station as a preset and select, it will not lose the spot on the preset list and will continue from that station to the next preset with the steering controls.
Trying to see f anyone had my problem and got it fixed.
 
Back
Top