INSTALL HELP - upfitter switch wiring

adrienneweld

Tremor Buff
Joined
Jan 3, 2021
Messages
79
Reaction Points
364
Location
PNW
Current Ride
2021 F250 Platinum Tremor
I’m trying to install my linkable lights to the upfitter switches — the directions say to connect the splice connector onto the splice harness... the problem is there are 3 wires, not just one wire to aux and one to ground. What’s the 3rd for??

There’s a green, white and then the black/ground.

There’s nothing in the instructions that talk about the two wires (green vs white). My understanding was the lights were either on or off.

Had anyone else installed these lights and know if each wire is supposed to go to a different Aux #? or what??
 
are all the lights the same?
maybe you have 2 sets that can be individually toggled?
 
I’m trying to install my linkable lights to the upfitter switches — the directions say to connect the splice connector onto the splice harness... the problem is there are 3 wires, not just one wire to aux and one to ground. What’s the 3rd for??

There’s a green, white and then the black/ground.

There’s nothing in the instructions that talk about the two wires (green vs white). My understanding was the lights were either on or off.

Had anyone else installed these lights and know if each wire is supposed to go to a different Aux #? or what??
Hey there. Where are all those pics. You showing off tons of pics and now seems like I haven’t seen any. Show off that beautiful Platty.
????????
 
Hey there. Where are all those pics. You showing off tons of pics and now seems like I haven’t seen any. Show off that beautiful Platty.
????????
are you being helpful??? ?

i can’t post more pictures until these damn lights are connected!

4620CC4D-3DBC-49A2-B827-315DDD9C6E31.jpeg
 
are all the lights the same?
maybe you have 2 sets that can be individually toggled?
they aren’t all the same — but i’m pretty sure they’re all either on or off.
 
are you being helpful??? ?

i can’t post more pictures until these damn lights are connected!

View attachment 14231
So sorry but yeah I’m no help just a fan. I haven’t seen you on here so I thought I’d give a shout.
Those lights look SWEET.
VERY SEXY LOOKING BEAST, FOR SURE
?
 
Pretty sure the green you don’t connect. I know with VisionX I don’t connect it and it works, I believe it’s if you want to put it on a dimmer (PWM).
 
From what I could tell from doing more research last night was that the green wire is control... Maybe there’s another wire in the aux switch wire bundle that it should be connected to?

Also, do I need to cut off the black end cap before placing the wire in the splice connector?

A9C4787F-0CED-4BB2-8A08-E85F4F31C37C.jpeg
88EBCA86-0C40-4912-9820-996CF994822D.jpeg
 
Those black caps are for splicing you lay the wire in the other track squeeze down with pliers and it splices in I use the wire tester to find number one Upfitter switch
 
Those black caps are for splicing you lay the wire in the other track squeeze down with pliers and it splices in I use the wire tester to find number one Upfitter switch
Awesome — thank you ??

That’s what I thought but didn’t want to do something without being 100% sure first.

Any clue about the green/control wire?
 
I’m not sure on that one mine did not have it you could test it with a low volt power see if it’s a high low
 
Did you try googling the model number on that light bar see if anything showed up
 
Does it make sense that the white wire from the harness goes to the 20A B+, green to AUX1 and black to ground?
 
Did you try googling the model number on that light bar see if anything showed up
I tried researching everything — spent hours yesterday trying to figure it out.
 
I tried researching everything — spent hours yesterday trying to figure it out.
It’s almost like it’s wired like a house fixture online shows green to body black to battery negative white to power but I’m not for sure
 
It’s almost like it’s wired like a house fixture online shows green to body black to battery negative white to power but I’m not for sure
after some trial and error we left the green disconnected. connected white/power to AUX1 and connected the ground to the battery.

we tried running the green wire to the 20A B+ which ended up being constant power even with accessory and truck off.

then we tried running green to run/start — which ended up being constant power with accessory on.

soooo we just left it disconnected... would LOVE to know what it’s actually supposed to do or go to, but for now at least the lights with AUX work.
 
image.jpg

Maybe I missed something but this is what you get for directions, not super clear for a simpleton. ?
 
Glad I ordered mine installed. Course it will be installed in a truck someone else will get.
 
This won't help answer the specific question, but it may help others planning to use the upfitter wiring. I have a number of additions that will use the switches and I hate butt connectors and tap splices. I'm a huge fan of Deutsche Connectors and used the DTP Series because they're rated to handle the 25 amp capacity of switches one through four. The DTP series are available in two and four pin, so pins one through four in the connector are tied to the specific AUX switches one through four. I use the solid pins, not the stamped and formed pins and have the crimpers on-hand from all my custom motorcycle builds.

Switches five and six are rated for 40 amps, so I used single pin connectors rated to handle the heavier loads on switches five and six. These connectors make for a very clean install and if service is needed, just unplug the connectors instead of cutting wires.


If you plan to do a lot of wiring work, various kits are available as well. I keep the kits in the shop for the bike projects....

Hope this helps.
MB
 
You’re always a huge help to everyone MB. You are the man Ravage88. ??????????????????✌️✌️✌️?
 
Back
Top