Eco

Flatland

Tremor Newbie
Joined
Nov 2, 2020
Messages
2
Reaction Points
1
Location
32952
Current Ride
2020 F250 Super Duty Tremor
I run my truck in ECO mode most of the time. It increases fuel economy by about 10%. Sometimes when I start up the truck, it asks me if I want to "return to ECO", sometimes it does not. Sometimes it just starts up in ECO, sometimes it does not. Any ideas why this happens?
 
I run my truck in ECO mode most of the time. It increases fuel economy by about 10%. Sometimes when I start up the truck, it asks me if I want to "return to ECO", sometimes it does not. Sometimes it just starts up in ECO, sometimes it does not. Any ideas why this happens?
I've noticed the same thing. Without any research it seems to be a time based thing. I know if it goes over night it asks me on the first startup of the day but then just starts in that mode after that on the same day.
 
I've noticed the same thing. Without any research it seems to be a time based thing. I know if it goes over night it asks me on the first startup of the day but then just starts in that mode after that on the same day.
it is time based... and if it is the same day as well
 
Sounds like my memory seats, sometimes they are not.
 
Sounds like my memory seats, sometimes they are not.
you should link your seat settings to your key fob.... once i did that they ALWAYS are set
 
Ohhhh, technology, I will look into that.....thanks.?
i have it for all the ford .... when i drive to 2018 edge my gf has her seat settings and i have mine .... and it nice to just hit the unlock button on the fob or just open the driver door and the seat and wheel and mirrors all go to my settings .... the mirrors moving it the BEST thing i love .... i hate having to move mirrors every time i get it


all you have to do it set your setting hold the 1, 2, or 3 and it save your settings but if you hold for 5 sec i believe it will say link to key .... make sure you only have one key fob in the vehicle .... works on all fords with memory seats
 
I run my truck in ECO mode most of the time. It increases fuel economy by about 10%. Sometimes when I start up the truck, it asks me if I want to "return to ECO", sometimes it does not. Sometimes it just starts up in ECO, sometimes it does not. Any ideas why this happens?

I'll have to try this mode out on my next day trip and see what kinda difference it makes on a 200-300 mile round trip. I ran it for the first time yesterday and couldn't tell much of a difference with in town driving.
 
Back
Top